CVE

【漏洞预警】Spring Cloud Config 服务远程任意文件读取漏洞(CVE-2020-5405)

道锋潜鳞
2020-03-12 / 0 评论 / 3 阅读 / 正在检测是否收录...

漏洞描述

Spring Cloud Config一套开源分布式系统配置服务,为分布式环境提供外部配置服务支持。目前漏洞可利用PoC已在互联网上披露,

历史上Spring Cloud Config服务器于2019年4月17日曾爆发过任意文件读取漏洞(CVE-2019-3799),详情:http://help.aliyun.com/noticelist/articleid/1000130771.html


漏洞评级

CVE-2020-5405 高危

影响版本

2.2.x系列:< 2.2.2

2.1.x系列:< 2.1.7

其他较早版本

安全版本

2.2.x系列:2.2.2 及以上

2.1.x系列:2.1.7 及以上

安全建议

升级Spring Cloud Config至安全版本,并依据Spring官方文档对应用加固:https://cloud.spring.io/spring-cloud-config/multi/multi__spring_cloud_config_server.html#_security

相关链接

https://pivotal.io/security/cve-2020-5405

0

评论 (0)

取消